USN-2123-1: file vulnerabilities

Ubuntu Security Notice USN-2123-1

26th February, 2014

file vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

File could be made to crash if it processed a specially crafted file.

Software description

  • file - Tool to determine file types

Details

It was discovered that file incorrectly handled Composite Document files.
An attacker could use this issue to cause file to crash, resulting in a
denial of service. This issue only affected Ubuntu 10.04 LTS and Ubuntu
12.04 LTS. (CVE-2012-1571)

Bernd Melchers discovered that file incorrectly handled indirect offset
values. An attacker could use this issue to cause file to consume resources
or crash, resulting in a denial of service. (CVE-2014-1943)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
libmagic1 5.11-2ubuntu4.1
file 5.11-2ubuntu4.1
Ubuntu 12.10:
libmagic1 5.11-2ubuntu0.1
file 5.11-2ubuntu0.1
Ubuntu 12.04 LTS:
libmagic1 5.09-2ubuntu0.2
file 5.09-2ubuntu0.2
Ubuntu 10.04 LTS:
libmagic1 5.03-5ubuntu1.1
file 5.03-5ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2012-1571, CVE-2014-1943