USN-2090-1: Munin vulnerabilities

Ubuntu Security Notice USN-2090-1

27th January, 2014

munin vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS

Summary

Several security issues were fixed in Munin.

Software description

  • munin - Network-wide graphing framework

Details

Christoph Biedl discovered that Munin incorrectly handled certain
multigraph data. A remote attacker could use this issue to cause Munin to
consume resources, resulting in a denial of service. (CVE-2013-6048)

Christoph Biedl discovered that Munin incorrectly handled certain
multigraph service names. A remote attacker could use this issue to cause
Munin to stop data collection, resulting in a denial of service.
(CVE-2013-6359)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
munin 2.0.17-2ubuntu1.1
Ubuntu 12.10:
munin 2.0.2-1ubuntu2.3
Ubuntu 12.04 LTS:
munin 1.4.6-3ubuntu3.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-6048, CVE-2013-6359