USN-2061-1: OpenStack Keystone vulnerability

Ubuntu Security Notice USN-2061-1

19th December, 2013

keystone vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10

Summary

Keystone access controls could be circumvented via EC2-style tokens.

Software description

  • keystone - OpenStack identity service

Details

Steven Hardy discovered that Keystone did not properly enforce trusts when
using the ec2tokens API. An authenticated attacker could exploit this to
retrieve a token not scoped to the trust and elevate privileges to the
trustor's roles.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
python-keystone 1:2013.2-0ubuntu1.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-6391