USN-2059-1: GnuPG vulnerability

Ubuntu Security Notice USN-2059-1

18th December, 2013

gnupg vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 13.04
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

GnuPG could expose sensitive information when performing decryption.

Software description

  • gnupg - GNU privacy guard - a free PGP replacement

Details

Daniel Genkin, Adi Shamir, and Eran Tromer discovered that GnuPG was
susceptible to an adaptive chosen ciphertext attack via acoustic
emanations. A local attacker could use this attack to possibly recover
private keys.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
gnupg 1.4.14-1ubuntu2.1
Ubuntu 13.04:
gnupg 1.4.12-7ubuntu1.3
Ubuntu 12.10:
gnupg 1.4.11-3ubuntu4.4
Ubuntu 12.04 LTS:
gnupg 1.4.11-3ubuntu2.5
Ubuntu 10.04 LTS:
gnupg 1.4.10-2ubuntu1.5

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-4576