USN-2055-1: PHP vulnerabilities

Ubuntu Security Notice USN-2055-1

12th December, 2013

php5 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.10
  • Ubuntu 13.04
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 10.04 LTS

Summary

Several security issues were fixed in PHP.

Software description

  • php5 - HTML-embedded scripting language interpreter

Details

Stefan Esser discovered that PHP incorrectly parsed certificates. An
attacker could use a malformed certificate to cause PHP to crash, resulting
in a denial of service, or possibly execute arbitrary code. (CVE-2013-6420)

It was discovered that PHP incorrectly handled DateInterval objects. An
attacker could use this issue to cause PHP to crash, resulting in a denial
of service. (CVE-2013-6712)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.10:
php5-cli 5.5.3+dfsg-1ubuntu2.1
php5-cgi 5.5.3+dfsg-1ubuntu2.1
libapache2-mod-php5 5.5.3+dfsg-1ubuntu2.1
Ubuntu 13.04:
php5-cli 5.4.9-4ubuntu2.4
php5-cgi 5.4.9-4ubuntu2.4
libapache2-mod-php5 5.4.9-4ubuntu2.4
Ubuntu 12.10:
php5-cli 5.4.6-1ubuntu1.5
php5-cgi 5.4.6-1ubuntu1.5
libapache2-mod-php5 5.4.6-1ubuntu1.5
Ubuntu 12.04 LTS:
php5-cli 5.3.10-1ubuntu3.9
php5-cgi 5.3.10-1ubuntu3.9
libapache2-mod-php5 5.3.10-1ubuntu3.9
Ubuntu 10.04 LTS:
php5-cli 5.3.2-1ubuntu4.22
php5-cgi 5.3.2-1ubuntu4.22
libapache2-mod-php5 5.3.2-1ubuntu4.22

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-6420, CVE-2013-6712