USN-2028-1: Apache XML Security for Java vulnerability

Ubuntu Security Notice USN-2028-1

12th November, 2013

libxml-security-java vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.04 LTS

Summary

Apache XML Security for Java could be tricked into validating spoofed signatures.

Software description

  • libxml-security-java - implementation of security standards for XML

Details

James Forshaw discovered that Apache XML Security for Java incorrectly
validated CanonicalizationMethod parameters. An attacker could use this
flaw to spoof XML signatures.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 10.04 LTS:
libxml-security-java 1.4.3-2ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-2172