USN-1906-1: File Roller vulnerability

Ubuntu Security Notice USN-1906-1

16th July, 2013

file-roller vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.04
  • Ubuntu 12.10

Summary

File Roller could be made to create or overwrite files.

Software description

  • file-roller - archive manager for GNOME

Details

Yorick Koster discovered that File Roller incorrectly sanitized paths. If a
user were tricked into extracting a specially-crafted archive, an attacker
could create and overwrite files outside of the extraction directory.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.04:
file-roller 3.6.3-1ubuntu4.1
Ubuntu 12.10:
file-roller 3.6.1.1-0ubuntu1.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-4668