USN-1897-1: PyMongo vulnerability

Ubuntu Security Notice USN-1897-1

3rd July, 2013

pymongo vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.04
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS

Summary

PyMongo could be made to crash under certain conditions.

Software description

  • pymongo - Python interface to the MongoDB document-oriented database

Details

Jibbers McGee discovered that PyMongo incorrectly handled certain invalid
DBRefs. An attacker could use this issue to cause PyMongo to crash,
resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.04:
python-bson 2.2-4ubuntu0.1
python-bson-ext 2.2-4ubuntu0.1
Ubuntu 12.10:
python-bson 2.2-2ubuntu0.1
python-bson-ext 2.2-2ubuntu0.1
Ubuntu 12.04 LTS:
python-bson 2.1-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-2132