USN-1896-1: Module::Signature perl module vulnerability

Ubuntu Security Notice USN-1896-1

3rd July, 2013

libmodule-signature-perl vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.04
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS

Summary

Module::Signature could be made to run programs if it verified a signature.

Software description

  • libmodule-signature-perl - module to manipulate CPAN SIGNATURE files

Details

Florian Weimer discovered that the Module::Signature perl module
incorrectly loaded unknown ciphers from relative directories. An attacker
could possibly use this flaw to execute arbitrary code when a signature is
verified.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.04:
libmodule-signature-perl 0.68-1ubuntu0.13.04.1
Ubuntu 12.10:
libmodule-signature-perl 0.68-1ubuntu0.12.10.1
Ubuntu 12.04 LTS:
libmodule-signature-perl 0.68-1ubuntu0.12.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-2145