USN-1856-1: libxcursor vulnerability

Ubuntu Security Notice USN-1856-1

5th June, 2013

libxcursor vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.04
  • Ubuntu 12.10
  • Ubuntu 12.04 LTS

Summary

Several security issues were fixed in libxcursor.

Software description

  • libxcursor - X cursor management library

Details

Ilja van Sprundel discovered multiple security issues in various X.org
libraries and components. An attacker could use these issues to cause
applications to crash, resulting in a denial of service, or possibly
execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.04:
libxcursor1 1:1.1.13-1ubuntu0.13.04.1
Ubuntu 12.10:
libxcursor1 1:1.1.13-1ubuntu0.12.10.1
Ubuntu 12.04 LTS:
libxcursor1 1:1.1.12-1ubuntu0.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart your session to make all
the necessary changes.

References

CVE-2013-2003