USN-1817-1: libxml2 vulnerability

Ubuntu Security Notice USN-1817-1

7th May, 2013

libxml2 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 13.04

Summary

libxml2 could be made to crash or run programs if it opened a specially crafted file.

Software description

  • libxml2 - GNOME XML library

Details

It was discovered that libxml2 incorrectly handled memory management when
parsing certain XML files. An attacker could use this flaw to cause libxml2
to crash, resulting in a denial of service, or to possibly execute
arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 13.04:
libxml2 2.9.0+dfsg1-4ubuntu4.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

CVE-2013-1969