USN-1770-1: Perl vulnerability

Ubuntu Security Notice USN-1770-1

19th March, 2013

perl vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 11.10
  • Ubuntu 10.04 LTS
  • Ubuntu 8.04 LTS

Summary

Perl could be made to stop responding if it received specially crafted input.

Software description

  • perl - Practical Extraction and Report Language

Details

Yves Orton discovered that Perl incorrectly handled hashing when using
user-provided hash keys. An attacker could use this flaw to perform a
denial of service attack against software written in Perl.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.10:
perl 5.14.2-13ubuntu0.2
Ubuntu 12.04 LTS:
perl 5.14.2-6ubuntu2.3
Ubuntu 11.10:
perl 5.12.4-4ubuntu0.2
Ubuntu 10.04 LTS:
perl 5.10.1-8ubuntu2.3
Ubuntu 8.04 LTS:
perl 5.8.8-12ubuntu0.8

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-1667