USN-1747-1: Transmission vulnerability

Ubuntu Security Notice USN-1747-1

25th February, 2013

transmission vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 11.10

Summary

Transmission could be made to crash or run programs if it received specially crafted network traffic.

Software description

  • transmission - lightweight BitTorrent client

Details

It was discovered that Transmission incorrectly handled certain micro
transport protocol packets. A remote attacker could use this issue to cause
a denial of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.10:
transmission-common 2.61-0ubuntu2.2
Ubuntu 12.04 LTS:
transmission-common 2.51-0ubuntu1.3
Ubuntu 11.10:
transmission-common 2.33-0ubuntu2.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart Transmission to make all
the necessary changes.

References

CVE-2012-6129