USN-1734-1: OpenStack Nova vulnerability

Ubuntu Security Notice USN-1734-1

21st February, 2013

nova vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 11.10

Summary

Nova could be made to crash if it received specially crafted input.

Software description

  • nova - OpenStack Compute cloud infrastructure

Details

Joshua Harlow discovered that Nova would allow XML entity processing. A
remote unauthenticated attacker could exploit this using the Nova API to
cause a denial of service via resource exhaustion. (CVE-2013-1664)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.10:
python-nova 2012.2.1+stable-20121212-a99a802e-0ubuntu1.2
Ubuntu 12.04 LTS:
python-nova 2012.1.3+stable-20120827-4d2a4afe-0ubuntu1.2
Ubuntu 11.10:
python-nova 2011.3-0ubuntu6.12

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-1664