USN-1709-1: OpenStack Nova vulnerability

Ubuntu Security Notice USN-1709-1

29th January, 2013

nova vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 11.10

Summary

Nova volume could be made to expose volumes from other users.

Software description

  • nova - OpenStack Compute cloud infrastructure

Details

Phil Day discovered that nova-volume did not validate access to volumes. An
authenticated attacker could exploit this to bypass intended access
controls and boot from arbitrary volumes.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.10:
nova-volume 2012.2.1+stable-20121212-a99a802e-0ubuntu1.1
python-nova 2012.2.1+stable-20121212-a99a802e-0ubuntu1.1
Ubuntu 12.04 LTS:
nova-volume 2012.1.3+stable-20120827-4d2a4afe-0ubuntu1.1
python-nova 2012.1.3+stable-20120827-4d2a4afe-0ubuntu1.1
Ubuntu 11.10:
nova-volume 2011.3-0ubuntu6.11
python-nova 2011.3-0ubuntu6.11

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-0208