USN-1668-1: Apport update

Ubuntu Security Notice USN-1668-1

17th December, 2012

apport update

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS
  • Ubuntu 11.10
  • Ubuntu 10.04 LTS

Summary

A hardening measure was added to apport.

Software description

  • apport - automatically generate crash reports for debugging

Details

Dan Rosenberg discovered that an application running under an AppArmor
profile that allowed unconfined execution of apport-bug could escape
confinement by calling apport-bug with a crafted environment. While not a
vulnerability in apport itself, this update mitigates the issue by
sanitizing certain variables in the apport-bug shell script.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.04 LTS:
apport 2.0.1-0ubuntu15.1
Ubuntu 11.10:
apport 1.23-0ubuntu4.1
Ubuntu 10.04 LTS:
apport 1.13.3-0ubuntu2.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

LP: 1045986