USN-1663-1: Nova vulnerability

Ubuntu Security Notice USN-1663-1

12th December, 2012

nova vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.10

Summary

Nova could be made to expose sensitive information.

Software description

  • nova - OpenStack Compute cloud infrastructure

Details

Eric Windisch discovered that Nova did not properly clear LVM-backed images
before they were reallocated which could potentially lead to an information
leak. This issue only affected setups using libvirt LVM-backed instances.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.10:
python-nova 2012.2-0ubuntu5.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2012-5625