USN-1632-2: Django regression

Ubuntu Security Notice USN-1632-2

20th November, 2012

python-django regression

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.10
  • Ubuntu 12.04 LTS
  • Ubuntu 11.10
  • Ubuntu 10.04 LTS

Summary

A testsuite regression was fixed in Django.

Software description

  • python-django - High-level Python web development framework

Details

USN-1632-1 fixed a vulnerability in Django. The upstream fix introduced
testsuite failures when ADMINS and/or MANAGERS were defined in settings.py.
This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

James Kettle discovered Django did not properly filter the Host HTTP header
when processing certain requests. An attacker could exploit this to
generate and display arbitrary URLs to users.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.10:
python-django 1.4.1-2ubuntu0.2
Ubuntu 12.04 LTS:
python-django 1.3.1-4ubuntu1.4
Ubuntu 11.10:
python-django 1.3-2ubuntu1.5
Ubuntu 10.04 LTS:
python-django 1.1.1-2ubuntu1.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

LP: 1080204