USN-1623-1: Mesa vulnerability

Ubuntu Security Notice USN-1623-1

5th November, 2012

mesa vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS

Summary

Mesa could be made to crash or run programs if it processed specially crafted data.

Software description

  • mesa - free implementation of the EGL API

Details

It was discovered that Mesa incorrectly handled certain arrays. An attacker
could use this issue to cause Mesa to crash, resulting in a denial of
service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.04 LTS:
libgl1-mesa-dri 8.0.4-0ubuntu0.2
libglu1-mesa 8.0.4-0ubuntu0.2
libgl1-mesa-glx 8.0.4-0ubuntu0.2
libosmesa6 8.0.4-0ubuntu0.2
libglapi-mesa 8.0.4-0ubuntu0.2
libopenvg1-mesa 8.0.4-0ubuntu0.2
libgles2-mesa 8.0.4-0ubuntu0.2
libegl1-mesa 8.0.4-0ubuntu0.2
libxatracker1 8.0.4-0ubuntu0.2
libgles1-mesa 8.0.4-0ubuntu0.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

CVE-2012-2864