USN-1591-1: xdiagnose update

Ubuntu Security Notice USN-1591-1

2nd October, 2012

xdiagnose update

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS


3rd party applications using xdiagnose could potentially be made to overwrite files.

Software description

  • xdiagnose - diagnosis tool


Alec Warner discovered that xdiagnose improperly handled temporary files
in when creating user-initiated archive files. While failsafeX
does not use the vulnerable code, this update removes this functionality to
protect any 3rd party applications which import the vulnerable code. In the
default Ubuntu installation, this should be prevented by the Yama link

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.04 LTS:
xdiagnose 2.5.2ubuntu0.1

To update your system, please follow these instructions:

In general, a standard system update will make all the necessary changes.


LP: 1036211