USN-1564-1: OpenStack Keystone vulnerability

Ubuntu Security Notice USN-1564-1

13th September, 2012

keystone vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS

Summary

OpenStack Keystone did not properly handle user role changes

Software description

  • keystone - OpenStack identity service

Details

Dolph Mathews discovered that when roles are granted and revoked to
users in Keystone, pre-existing tokens were not updated or invalidated
to take the new roles into account. An attacker could use this to
continue to access resources that have been revoked.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.04 LTS:
keystone 2012.1+stable~20120824-a16a0ab9-0ubuntu2.2
python-keystone 2012.1+stable~20120824-a16a0ab9-0ubuntu2.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2012-4413