USN-1545-1: Nova vulnerability

Ubuntu Security Notice USN-1545-1

22nd August, 2012

nova vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS
  • Ubuntu 11.10

Summary

Nova could be made to overwrite or corrupt arbitrary files in the compute host file system.

Software description

  • nova - OpenStack Compute cloud infrastructure

Details

Padraig Brady discovered that the fix for CVE-2012-3361 was incomplete and
an authenticated user could still corrupt arbitrary files on the host
running Nova. A remote attacker could use this to cause a denial of service
or possibly gain privileges.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.04 LTS:
python-nova 2012.1+stable~20120612-3ee026e-0ubuntu1.3
Ubuntu 11.10:
python-nova 2011.3-0ubuntu6.10

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2012-3447