USN-1493-1: Linux kernel vulnerabilities

Ubuntu Security Notice USN-1493-1

29th June, 2012

linux vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.04 LTS

Summary

Several security issues were fixed in the kernel.

Software description

  • linux - Linux kernel

Details

Stephan Mueller reported a flaw in the Linux kernel's dl2k network driver's
handling of ioctls. An unprivileged local user could leverage this flaw to
cause a denial of service. (CVE-2012-2313)

Timo Warns reported multiple flaws in the Linux kernel's hfsplus
filesystem. An unprivileged local user could exploit these flaws to gain
root system priviliges. (CVE-2012-2319)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 8.04 LTS:
linux-image-2.6.24-31-powerpc 2.6.24-31.102
linux-image-2.6.24-31-sparc64 2.6.24-31.102
linux-image-2.6.24-31-virtual 2.6.24-31.102
linux-image-2.6.24-31-server 2.6.24-31.102
linux-image-2.6.24-31-hppa32 2.6.24-31.102
linux-image-2.6.24-31-lpiacompat 2.6.24-31.102
linux-image-2.6.24-31-rt 2.6.24-31.102
linux-image-2.6.24-31-lpia 2.6.24-31.102
linux-image-2.6.24-31-generic 2.6.24-31.102
linux-image-2.6.24-31-hppa64 2.6.24-31.102
linux-image-2.6.24-31-mckinley 2.6.24-31.102
linux-image-2.6.24-31-xen 2.6.24-31.102
linux-image-2.6.24-31-powerpc64-smp 2.6.24-31.102
linux-image-2.6.24-31-itanium 2.6.24-31.102
linux-image-2.6.24-31-openvz 2.6.24-31.102
linux-image-2.6.24-31-386 2.6.24-31.102
linux-image-2.6.24-31-sparc64-smp 2.6.24-31.102
linux-image-2.6.24-31-powerpc-smp 2.6.24-31.102

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

CVE-2012-2313, CVE-2012-2319