USN-1485-1: AccountsService vulnerability

Ubuntu Security Notice USN-1485-1

28th June, 2012

accountsservice vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS
  • Ubuntu 11.10

Summary

AccountsService could be made to read arbitrary files as the administrator.

Software description

  • accountsservice - query and manipulate user account information

Details

Florian Weimer discovered that AccountsService incorrectly handled
privileges when copying certain files to the system cache directory. A
local attacker could exploit this issue to read arbitrary files, bypassing
intended permissions.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.04 LTS:
accountsservice 0.6.15-2ubuntu9.1
libaccountsservice0 0.6.15-2ubuntu9.1
Ubuntu 11.10:
accountsservice 0.6.14-1git1ubuntu1.2
libaccountsservice0 0.6.14-1git1ubuntu1.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to reboot your computer to make
all the necessary changes.

References

CVE-2012-2737