USN-1466-1: Nova vulnerability

Ubuntu Security Notice USN-1466-1

6th June, 2012

nova vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS
  • Ubuntu 11.10

Summary

Nova could be prevented from applying security group policy.

Software description

  • nova - OpenStack Compute cloud infrastructure

Details

It was discovered that, when defining security groups in Nova using
the EC2 or OS APIs, specifying the network protocol (e.g. 'TCP') in
the incorrect case would cause the security group to not be applied
correctly. An attacker could use this to bypass Nova security group
restrictions.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.04 LTS:
python-nova 2012.1-0ubuntu2.2
Ubuntu 11.10:
python-nova 2011.3-0ubuntu6.7

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2012-2654