USN-1443-2: Update Manager vulnerability

Ubuntu Security Notice USN-1443-2

4th June, 2012

update-manager vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.04 LTS
  • Ubuntu 11.10
  • Ubuntu 11.04

Summary

Update Manager could expose sensitive information in certain circumstances.

Software description

  • update-manager - GNOME application that manages apt updates

Details

USN-1443-1 fixed vulnerabilities in Update Manager. The fix for
CVE-2012-0949 was discovered to be incomplete. This update fixes the
problem.

Original advisory details:

Felix Geyer discovered that the Update Manager Apport hook incorrectly
uploaded certain system state archive files to Launchpad when reporting
bugs. This could possibly result in repository credentials being included
in public bug reports. (CVE-2012-0949)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.04 LTS:
update-manager-core 1:0.156.14.5
Ubuntu 11.10:
update-manager-core 1:0.152.25.12
Ubuntu 11.04:
update-manager-core 1:0.150.5.4

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2012-0950