USN-1222-1: Firefox vulnerabilities

Ubuntu Security Notice USN-1222-1

29th September, 2011

Firefox vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.04

Summary

Firefox could be made to crash or possibly run programs as your login if it opened a malicious website.

Software description

  • firefox - Mozilla Open Source web browser

Details

Benjamin Smedberg, Bob Clary, Jesse Ruderman, Bob Clary, Andrew McCreight,
Andreas Gal, Gary Kwong, Igor Bukanov, Jason Orendorff, Jesse Ruderman, and
Marcia Knous discovered multiple memory vulnerabilities in the browser
rendering engine. An attacker could use these to possibly execute arbitrary
code with the privileges of the user invoking Firefox. (CVE-2011-2995,
CVE-2011-2997)

Boris Zbarsky discovered that a frame named "location" could shadow the
window.location object unless a script in a page grabbed a reference to the
true object before the frame was created. This is in violation of the Same
Origin Policy. A malicious website could possibly use this to access
another website or the local file system. (CVE-2011-2999)

Ian Graham discovered that when multiple Location headers were present,
Firefox would use the second one resulting in a possible CRLF injection
attack. CRLF injection issues can result in a wide variety of attacks, such
as XSS (Cross-Site Scripting) vulnerabilities, browser cache poisoning, and
cookie theft. (CVE-2011-3000)

Mariusz Mlynski discovered that if the user could be convinced to hold down
the enter key, a malicious website could potential pop up a download dialog
and the default open action would be selected or lead to the installation
of an arbitrary add-on. This would result in potentially malicious content
being run with privileges of the user invoking Firefox. (CVE-2011-2372,
CVE-2011-3001)

Michael Jordon and Ben Hawkes discovered flaws in WebGL. If a user were
tricked into opening a malicious page, an attacker could cause the browser
to crash. (CVE-2011-3002, CVE-2011-3003)

It was discovered that Firefox did not properly free memory when processing
ogg files. If a user were tricked into opening a malicious page, an
attacker could cause the browser to crash. (CVE-2011-3005)

David Rees and Aki Helin discovered a problems in the JavaScript engine. An
attacker could exploit this to crash the browser or potentially escalate
privileges within the browser. (CVE-2011-3232)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 11.04:
firefox 7.0.1+build1+nobinonly-0ubuntu0.11.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart Firefox to make all the
necessary changes.

References

CVE-2011-2372, CVE-2011-2995, CVE-2011-2997, CVE-2011-2999, CVE-2011-3000, CVE-2011-3001, CVE-2011-3002, CVE-2011-3003, CVE-2011-3004, CVE-2011-3005, CVE-2011-3232