USN-899-1: Tomcat vulnerabilities

Ubuntu Security Notice USN-899-1

11th February, 2010

tomcat6 vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.10

Software description

  • tomcat6

Details

It was discovered that Tomcat did not correctly validate WAR filenames or
paths when deploying. A remote attacker could send a specially crafted WAR
file to be deployed and cause arbitrary files and directories to be
created, overwritten, or deleted.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.10:
libtomcat6-java 6.0.20-2ubuntu2.1
Ubuntu 9.04:
libtomcat6-java 6.0.18-0ubuntu6.2
Ubuntu 8.10:
libtomcat6-java 6.0.18-0ubuntu3.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-2693, CVE-2009-2901, CVE-2009-2902