USN-887-1: LibThai vulnerability

Ubuntu Security Notice USN-887-1

18th January, 2010

libthai vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.10
  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS

Software description

  • libthai

Details

Tim Starling discovered that LibThai did not correctly handle long strings.
A remote attacker could use specially-formed strings to execute arbitrary
code with the user's privileges.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.10:
libthai0 0.1.12-1ubuntu0.2
Ubuntu 9.04:
libthai0 0.1.9-4ubuntu0.9.04.2
Ubuntu 8.10:
libthai0 0.1.9-4ubuntu0.8.10.2
Ubuntu 8.04 LTS:
libthai0 0.1.9-1ubuntu0.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-4012