USN-850-1: poppler vulnerabilities

Ubuntu Security Notice USN-850-1

21st October, 2009

poppler vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software description

  • poppler

Details

It was discovered that poppler contained multiple security issues when
parsing malformed PDF documents. If a user or automated system were tricked
into opening a crafted PDF file, an attacker could cause a denial of
service or execute arbitrary code with privileges of the user invoking the
program.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.04:
libpoppler-glib4 0.10.5-1ubuntu2.4
libpoppler4 0.10.5-1ubuntu2.4
Ubuntu 8.10:
libpoppler3 0.8.7-1ubuntu0.4
libpoppler-glib3 0.8.7-1ubuntu0.4
Ubuntu 8.04 LTS:
libpoppler2 0.6.4-1ubuntu3.3
libpoppler-glib2 0.6.4-1ubuntu3.3
Ubuntu 6.06 LTS:
libpoppler1 0.5.1-0ubuntu7.6
libpoppler1-glib 0.5.1-0ubuntu7.6

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-0755, CVE-2009-3603, CVE-2009-3604, CVE-2009-3605, CVE-2009-3607, CVE-2009-3608, CVE-2009-3609