USN-842-1: Wget vulnerability

Ubuntu Security Notice USN-842-1

6th October, 2009

wget vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software description

  • wget

Details

It was discovered that Wget did not correctly handle SSL certificates with
zero bytes in the Common Name. A remote attacker could exploit this to
perform a man in the middle attack to view sensitive information or alter
encrypted communications.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.04:
wget 1.11.4-2ubuntu1.1
Ubuntu 8.10:
wget 1.11.4-1ubuntu1.1
Ubuntu 8.04 LTS:
wget 1.10.2-3ubuntu1.1
Ubuntu 6.06 LTS:
wget 1.10.2-1ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-3490