USN-840-1: OpenOffice.org vulnerabilities

Ubuntu Security Notice USN-840-1

1st October, 2009

openoffice.org vulnerabilities

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS

Software description

  • openoffice.org

Details

Dyon Balding discovered flaws in the way OpenOffice.org handled tables. If
a user were tricked into opening a specially crafted Word document, a
remote attacker might be able to execute arbitrary code with user
privileges. (CVE-2009-0200, CVE-2009-0201)

A memory overflow flaw was discovered in OpenOffice.org's handling of EMF
files. If a user were tricked into opening a specially crafted document, a
remote attacker might be able to execute arbitrary code with user
privileges. (CVE-2009-2139)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.04:
openoffice.org-core 1:3.0.1-9ubuntu3.1
Ubuntu 8.10:
openoffice.org-core 1:2.4.1-11ubuntu2.2
Ubuntu 8.04 LTS:
openoffice.org-core 1:2.4.1-1ubuntu2.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart OpenOffice.org to
effect the necessary changes.

References

CVE-2009-0200, CVE-2009-0201, CVE-2009-2139