USN-837-1: Newt vulnerability

Ubuntu Security Notice USN-837-1

24th September, 2009

newt vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software description

  • newt

Details

Miroslav Lichvar discovered that Newt incorrectly handled rendering in a
text box. An attacker could exploit this and cause a denial of service or
possibly execute arbitrary code with the privileges of the user invoking
the program.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.04:
libnewt0.52 0.52.2-11.3ubuntu3.1
Ubuntu 8.10:
libnewt0.52 0.52.2-11.3ubuntu1.1
Ubuntu 8.04 LTS:
libnewt0.52 0.52.2-11.2ubuntu1.1
Ubuntu 6.06 LTS:
libnewt0.51 0.51.6-31ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-2905