USN-824-1: PHP vulnerability

Ubuntu Security Notice USN-824-1

24th August, 2009

php5 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software description

  • php5

Details

It was discovered that PHP did not properly handle certain malformed
JPEG images when being parsed by the Exif module. A remote attacker could
exploit this flaw and cause the PHP server to crash, resulting in a denial
of service.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.04:
php5-cli 5.2.6.dfsg.1-3ubuntu4.2
php5-cgi 5.2.6.dfsg.1-3ubuntu4.2
Ubuntu 8.10:
php5-cli 5.2.6-2ubuntu4.3
php5-cgi 5.2.6-2ubuntu4.3
Ubuntu 8.04 LTS:
php5-cli 5.2.4-2ubuntu5.7
php5-cgi 5.2.4-2ubuntu5.7
Ubuntu 6.06 LTS:
php5-cli 5.1.2-1ubuntu3.15
php5-cgi 5.1.2-1ubuntu3.15

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-2687