USN-804-1: PulseAudio vulnerability

Ubuntu Security Notice USN-804-1

16th July, 2009

pulseaudio vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS

Software description

  • pulseaudio

Details

Tavis Ormandy, Julien Tinnes, and Yorick Koster discovered that PulseAudio did not
safely re-execute itself. A local attacker could exploit this to gain
root privileges.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.04:
pulseaudio 1:0.9.14-0ubuntu20.2
Ubuntu 8.10:
pulseaudio 0.9.10-2ubuntu9.4
Ubuntu 8.04 LTS:
pulseaudio 0.9.10-1ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-1894