USN-791-3: Smarty vulnerability

Ubuntu Security Notice USN-791-3

24th June, 2009

smarty vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04

Software description

  • smarty

Details

It was discovered that Smarty did not correctly filter certain math
inputs. A remote attacker using Smarty via a web service could exploit
this to execute subsets of shell commands as the web server user.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.04:
smarty 2.6.22-1ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-1669