USN-766-1: acpid vulnerability

Ubuntu Security Notice USN-766-1

27th April, 2009

acpid vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 9.04
  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software description

  • acpid

Details

It was discovered that acpid did not properly handle a large number of
connections. A local user could exploit this and monopolize CPU resources,
leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 9.04:
acpid 1.0.6-9ubuntu4.9.04.2
Ubuntu 8.10:
acpid 1.0.6-9ubuntu4.8.10.2
Ubuntu 8.04 LTS:
acpid 1.0.4-5ubuntu9.3
Ubuntu 6.06 LTS:
acpid 1.0.4-1ubuntu11.2

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-0798