USN-729-1: Python Crypto vulnerability

Ubuntu Security Notice USN-729-1

5th March, 2009

python-crypto vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 6.06 LTS

Software description

  • python-crypto

Details

Mike Wiacek discovered that the ARC2 implementation in Python Crypto
did not correctly check the key length. If a user or automated system
were tricked into processing a malicious ARC2 stream, a remote attacker
could execute arbitrary code or crash the application using Python Crypto,
leading to a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 8.10:
python-crypto 2.0.1+dfsg1-2.3ubuntu0.1
Ubuntu 8.04 LTS:
python-crypto 2.0.1+dfsg1-2.1ubuntu1.1
Ubuntu 7.10:
python-crypto 2.0.1+dfsg1-2ubuntu1.1
Ubuntu 6.06 LTS:
python2.4-crypto 2.0.1+dfsg1-1ubuntu1.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References

CVE-2009-0544