USN-725-1: KMail vulnerability

Ubuntu Security Notice USN-725-1

26th February, 2009

kdepim vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 6.06 LTS

Software description

  • kdepim

Details

It was discovered that Kmail did not adequately prevent execution of arbitrary
code when a user clicked on a URL to an executable within an HTML mail. If a
user clicked on a malicious URL and chose to execute the file, a remote
attacker could execute arbitrary code with user privileges. This update changes
KMail's behavior to instead launch a helper program to view the file if the
user chooses to execute such a link.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 8.10:
kmail 4:4.1.4-0ubuntu1~intrepid2.1
Ubuntu 8.04 LTS:
kmail 4:3.5.10-0ubuntu1~hardy3.1
Ubuntu 7.10:
kmail 4:3.5.7enterprise20070926-0ubuntu2.2
Ubuntu 6.06 LTS:
kmail 4:3.5.2-0ubuntu6.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart KMail to effect
the necessary changes.

References

LP: 332069