USN-687-1: nfs-utils vulnerability

Ubuntu Security Notice USN-687-1

4th December, 2008

nfs-utils vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 8.10
  • Ubuntu 8.04 LTS
  • Ubuntu 7.10
  • Ubuntu 6.06 LTS

Software description

  • nfs-utils

Details

It was discovered that nfs-utils did not properly enforce netgroup
restrictions when using TCP Wrappers. Remote attackers could bypass the
netgroup restrictions enabled by the administrator and possibly gain
access to sensitive information.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 8.10:
nfs-kernel-server 1:1.1.2-4ubuntu1.1
Ubuntu 8.04 LTS:
nfs-kernel-server 1:1.1.2-2ubuntu2.2
Ubuntu 7.10:
nfs-kernel-server 1:1.1.1~git-20070709-3ubuntu1.1
Ubuntu 6.06 LTS:
nfs-kernel-server 1:1.0.7-3ubuntu2.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system upgrade you need to restart nfs services to effect
the necessary changes.

References

CVE-2008-4552