USN-1772-1: OpenStack Keystone vulnerability

Ubuntu Security Notice USN-1772-1

20th March, 2013

keystone vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 12.10

Summary

Under certain configurations, Keystone would allow unintended access over the network.

Software description

  • keystone - OpenStack identity service

Details

Guang Yee discovered that Keystone would not always perform all
verification checks when configured to use PKI. If the keystone server was
configured to use PKI and services or users requested online verification,
an attacker could potentially exploit this to bypass revocation checks.
Keystone uses UUID tokens by default in Ubuntu.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 12.10:
python-keystone 2012.2.1-0ubuntu1.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2013-1865