USN-1360-1: Firefox vulnerability

Ubuntu Security Notice USN-1360-1

13th February, 2012

firefox vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.10
  • Ubuntu 11.04
  • Ubuntu 10.10
  • Ubuntu 10.04 LTS

Summary

A security vulnerability has been fixed in Firefox.

Software description

  • firefox - Mozilla Open Source web browser

Details

Andrew McCreight and Olli Pettay discovered a use-after-free vulnerability
in the XBL bindings. An attacker could exploit this to cause a denial of
service via application crash, or potentially execute code with the
privileges of the user invoking Firefox. (CVE-2012-0452)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 11.10:
firefox 10.0.1+build1-0ubuntu0.11.10.1
Ubuntu 11.04:
firefox 10.0.1+build1-0ubuntu0.11.04.1
Ubuntu 10.10:
firefox 10.0.1+build1-0ubuntu0.10.10.1
Ubuntu 10.04 LTS:
firefox 10.0.1+build1-0ubuntu0.10.04.1

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

After a standard system update you need to restart Firefox to make all the
necessary changes.

References

CVE-2012-0452, LP: 929833