USN-1135-1: Exim vulnerability

Ubuntu Security Notice USN-1135-1

25th May, 2011

exim4 vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 11.04
  • Ubuntu 10.10
  • Ubuntu 10.04 LTS

Summary

An attacker could send crafted input to Exim and cause it to run programs as the Exim user.

Software description

  • exim4 - metapackage to ease Exim MTA (v4) installation

Details

It was discovered that the Exim daemon did not correctly handle certain
DKIM identities. A remote attacker could send specially crafted email to
run arbitrary code as the Exim user.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 11.04:
exim4-daemon-heavy 4.74-1ubuntu1.2
exim4-daemon-custom 4.74-1ubuntu1.2
exim4-daemon-light 4.74-1ubuntu1.2
Ubuntu 10.10:
exim4-daemon-heavy 4.72-1ubuntu1.3
exim4-daemon-custom 4.72-1ubuntu1.3
exim4-daemon-light 4.72-1ubuntu1.3
Ubuntu 10.04 LTS:
exim4-daemon-heavy 4.71-3ubuntu1.3
exim4-daemon-custom 4.71-3ubuntu1.3
exim4-daemon-light 4.71-3ubuntu1.3

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2011-1407