USN-1075-1: Samba vulnerability

Ubuntu Security Notice USN-1075-1

28th February, 2011

samba vulnerability

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10
  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software description

  • samba

Details

Volker Lendecke discovered that Samba incorrectly handled certain file
descriptors. A remote attacker could send a specially crafted request to
the server and cause Samba to crash or hang, resulting in a denial of
service.

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 10.10:
samba 2:3.5.4~dfsg-1ubuntu8.3
Ubuntu 10.04 LTS:
samba 2:3.4.7~dfsg-1ubuntu3.4
Ubuntu 9.10:
samba 2:3.4.0-3ubuntu5.8
Ubuntu 8.04 LTS:
samba 3.0.28a-1ubuntu4.14
Ubuntu 6.06 LTS:
samba 3.0.22-1ubuntu3.14

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

CVE-2011-0719