USN-1042-2: PHP5 regression

Ubuntu Security Notice USN-1042-2

12th January, 2011

php5 regression

A security issue affects these releases of Ubuntu and its derivatives:

  • Ubuntu 10.10
  • Ubuntu 10.04 LTS
  • Ubuntu 9.10
  • Ubuntu 8.04 LTS
  • Ubuntu 6.06 LTS

Software description

  • php5

Details

USN-1042-1 fixed vulnerabilities in PHP5. The fix for CVE-2010-3436
introduced a regression in the open_basedir restriction handling code.
This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that attackers might be able to bypass open_basedir()
restrictions by passing a specially crafted filename. (CVE-2010-3436)

Update instructions

The problem can be corrected by updating your system to the following package version:

Ubuntu 10.10:
php5-cli 5.3.3-1ubuntu9.3
php5-cgi 5.3.3-1ubuntu9.3
libapache2-mod-php5 5.3.3-1ubuntu9.3
Ubuntu 10.04 LTS:
php5-cli 5.3.2-1ubuntu4.7
php5-cgi 5.3.2-1ubuntu4.7
libapache2-mod-php5 5.3.2-1ubuntu4.7
Ubuntu 9.10:
php5-cli 5.2.10.dfsg.1-2ubuntu6.7
php5-cgi 5.2.10.dfsg.1-2ubuntu6.7
libapache2-mod-php5 5.2.10.dfsg.1-2ubuntu6.7
Ubuntu 8.04 LTS:
php5-cli 5.2.4-2ubuntu5.14
php5-cgi 5.2.4-2ubuntu5.14
libapache2-mod-php5 5.2.4-2ubuntu5.14
Ubuntu 6.06 LTS:
php5-cli 5.1.2-1ubuntu3.21
php5-cgi 5.1.2-1ubuntu3.21
libapache2-mod-php5 5.1.2-1ubuntu3.21

To update your system, please follow these instructions: https://wiki.ubuntu.com/Security/Upgrades.

In general, a standard system update will make all the necessary changes.

References

LP: 701765